MQTT.fx 1.0.0 is here!

Time is passing by and since almost 2 years I am working on MQTT.fx.
During that time I released about 20 versions and I think I can justify the release of version 1.0.0.
There are still ideas for improvements and extensions but MQTT.fx is feature complete now (at least you can pup/sub to topics ;-)).


1.0.0 Release Notes

  • [Fixed] Issue #64: mqttfx-config.xml gets saturated with hundreds of topic in recentSubscriptionTopics
  • [New] Issue #59: Copy a topic in the message view
  • [New] Bundled with JRE 1.8.0_66
  • [Fixed] Issues with System MenuBar on OSX
  • [Fixed] Issue #58: Publish not working with 0.0.18
  • [Fixed] Issue #60: 0.0.18 Run hangs on quit
  • [Fixed] Issue #42: Ubuntu 14.04: Crash when trying to check for updates on launch
  • [Fixed] #57: Application crash on startup when found update available.

Blog Post: Walkthrough features [GER]


You can download latest binaries at
Bugs and feature requests can be reported via the issue tracker.

Recommended Reading

Comments Icon7 comments found on “MQTT.fx 1.0.0 is here!

  1. Hi !

    First, I would like to congratulate you for your awesome work on the MQTT.fx project.
    At present, I am a student in an engineer school and I am passionate about JavaFX. I have already developped JavaFX applications and to improve my general knowledge on this technology, I would like to know if it is possible to have an access on the whole source code? I would juste like to see how you built your application (main architecture) and how you handle all users events.

    Thanks in advance for your answer

    DELORME Loïc – Polytech Lyon – IT Dept – FRANCE

  2. Hi,
    MQTTfx is very useful tool to me.
    I am using MQTTfx v0.0.15 and I want to upgrade it to latest version.
    Would you please provide me a MQTT.fx v1.0.0 Windows 32bits version?
    Thank you in advance.

  3. hello sir, i try to download the latest version 1.0.0 , but my system says, bad quality of package and strongly recommended not to install, what should i do

  4. Yes 😉 Sorry for that. The System complains as of missing license information. etc. But you can savely install the package. Installation will only extract the needed files to /opt/MQTTfx


Your email address will not be published. Required fields are marked *